Lập kế hoạch và cấu hình VLAN cơ bản

Trong bài trước chúng ta đã làm quen với các khái niệm cơ bản về VLAN. Trong bài này, chúng ta sẽ đi tìm hiểu việc cấu hình VLAN cơ bản. Chúng ta sẽ sử dụng switch và router trên phần mềm giả lập Packet Tracer.

Giả định rằng bạn đã có hệ thống mạng đang hoạt động. Trước đây, với hệ thống mạng cũ, tất cả các máy của tất cả các phòng ban được đấu nối chung vào các switch trong hệ thống, các switch này là các switch thông thương không có khả năng chia VLAN.  Nhân sự của các phòng ban gia tăng nhanh chóng, đi cùng là số lượng máy tính và thiết bị gia tăng. Như vậy chúng ta có một miền Broadcast lớn và lúc này buộc lòng chúng ta phải có giả pháp để phân tách hệ thống mạng ra thành nhiều phần nhỏ.

Những điều như trên, đặt ra yêu cầu bạn phải có giải pháp phân tách mạng mình ra thành nhiều mạng nhỏ. Để làm điều đó, bạn có một vài phương pháp, cụ thể:

  • Cách 1: Bạn có thể sử dụng 1 máy tính, cài đặt các ứng dụng (ví dụ như cài đặt pfSense, Kerio Control), gắn nhiều card mạng, sau đó đấu nối đến các switch của các phòng ban. Cách này đơn giản, bạn có thể sử dụng hạ tầng cũ. Nhưng mỗi lần có yêu cầu thay đổi, như thay đổi vị trí chỗ ngồi của nhân viên các phòng ban, bạn lại phải chuyển đổi kết nối.
  • Cách 2: Bạn có thể triển khai các swicth cho phép thực hiện việc chia VLAN. Cách này cho phép bạn chuyển đổi các cổng trên switch về mạng mà mình mong muôn một cách nhanh nhất.

Để minh chứng cho hai điều trên ta đi vào ví dụ cụ thể sau, bạn được yêu cầu:

  • Phân chia nhỏ mạng thành các mạng của các phòng ban là Phòng kỹ thuật, Phòng kế toán, Phòng nhân sự, Phòng điều hành, Phòng IT và một mạng dành cho các thiết bị mạng, phân bố trên 3 tầng lầu.
  • Phải đảm bảo rằng các phòng ban phải đảm bảo rằng việc thay đổi vị trí chỗ ngồi cho các phòng ban là dễ dàng.
  • Phải đảm bảo rằng mỗi tầng trong toàn nhà phải có các máy in qua mạng và được quản lý chung.

Điều rõ ràng thấy là với yêu cầu đầu tiên, bạn có thể dễ dàng thực hiện với cách 1. Nhưng các yêu cầu 2 và 3 là rất khó thực hiện. Vậy cách khả thi nhất là bạn nên dùng các thiết bị có khả năng chia VLAN theo cách 2.

Sau khi phân tích các yêu cầu, như trên chúng ta tiến hành lên kế hoạch thực hiện.

Mô hình thiết lập như sau:

Khai báo các VLAN trên các switch:  Khai báo tất cả các VLAN cho các switch.

  • SWF1(config)#vlan 10
  • SWF1(config-vlan)#name Tech
  • SWF1(config-vlan)#exit

Thêm các port vào một VLAN: Đây là các port dùng để đấu nối với các thiết bị như máy tính.

  • SWF1(config)#interface range f0/1-10
  • SWF1(config-if-range)#switchport mode access
  • SWF1(config-if-range)#switchport access vlan 10

Cấu hính port Trunking trên các switch: Đấu nối giữa các switch và router để định tuyến

  • SWF1(config)#interface f0/24
  • SWF1(config-if)#switchport mode trunk

Cấu hính IP quản lý switch trên VLAN

  • SWF1(config)#interface vlan 60
  • SWF1(config-if)#ip address 192.168.60.1 255.255.255.0
  • SWF1(config-if)#exit
  • SWF1(config)#ip default-gateway 192.168.60.250

Bật cổng trên rau ter dùng để kết nôi các VLAN:

  • R1#configure terminal
  • R1(config)#interface f0/0
  • R1(config-if)#no shutdown

Tạo các subinterface để kết nối và định tuyến cho các VLAN:

  • R1(config)#interface f0/0.10
  • R1(config-subif)#encapsulation dot1Q 10
  • R1(config-subif)#ip address 192.168.10.250 255.255.255.0

Để tăng số port cho Access cho các VLAN, bạn có thể dùng các các switch thông thường (cũ) đấu nối vào các cổng Access Mode trên switch 2960. Biện pháp này giúp giảm chi phí cho việc nâng cấp hạ tầng.

Tải toàn bộ mô hình và code, mô hình chạy trên Packet Tracer 7.

Để kết nối và định tuyến các VLAN, ngoài router bạn có thê dùng pfSense.

Trên đây là cách phân tích, thiết kế và cấu hình cơ bản về VLAN trên thiết bị Cisco. Bạn có thể tham khảo và thiết kệ lại cho phù hợp với hệ thống của mình. Bạn lưu ý là ở đây chỉ cấu hình VLAN và không có các vấn đề khác như đặt password đăng nhập thiết bị, telnet, ssh hay mã hóa password. Trên cơ sở bài viết này, bạn có thể lập kế hoạch cho các thiết bị có hỗ trợ tính năng chia VLAN.

Sharing is caring!

Bài có liên quan